Frame Relay

Frame Relay Terms

LAR(Local Access rate) – the capacity of the local loop.

CIR(Committed Information Rate) – the capacity that you pay the ISP for.

FRAD(Frame Relay Access Device) – DTE router

DCE – configured on Frame Relay Switches

SVC(Switched Virtual Circuits) – established dynamically by sending signaling messages to the network (CALL SETUP, DATA TRANSFER, IDLE, CALL TERMINATION).

PVC(Permanent Virtual Circuits) – preconfigured by the carrier, and after they are set up, only operate in DATA TRANSFER and IDLE modes.

DLCI(Data Link Connection Identifier) – DLCI values typically are assigned by the Frame Relay service provider. Frame Relay DLCIs have local significance.

Inverse ARP – Helps a router to dinamically map an IPv4 address to a local DLCI.

LMI(Local Management Interface) – provides status information about Frame Relay connections between the router (DTE) and the Frame Relay switch (DCE). The FR switch and its connected router care about using the same LMI(cisco/ansi). The switch does not care about the encapsulation. The endpoint routers (DTEs) do care about the encapsulation(cisco/ietf).

FECN, BECN, DE – Congestion Control purposes

Frame Relay Topologies

  1. Hub and Spoke or Star(example below)
  2. Full Mesh
  3. Partial Mesh

Frame Relay Configurations

1. NBMA (point-to-multipoint/hub-and-spoke)

//Configure Frame Relay switch
S(config)#frame-relay switching
S(config)#interface s0
S(config-if)#encapsulation frame-relay
S(config-if)#clockrate 64000
S(config-if)#frame-relay intf-type dce
S(config-if)#frame-relay route 102 interface s1 201
S(config-if)#frame-relay route 103 interface s2 301
S(config-if)#no shutdown

//Static VC map on HUB
R1(config)#interface s0/0/0
R1(config-if)#ip address 10.0.0.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay map ip 10.0.0.2 102 broadcast cisco
R1(config-if)#frame-relay map ip 10.0.0.3 103 broadcast cisco
//in case you are using eigrp, you must run no ip split-horizon eigrp 1 , rip disables split-horizon when you enable frame-relay encapsulation
//for ospf the Hub must be the DR
//could also use IETF encapsulation when connecting to non-Cisco router
//The broadcast keyword specifies that broadcast and multicast traffic is allowed over the VC. This permits the use of dynamic routing protocols over the VC

//Static VC map on STOKE
R2(config)#interface s0/0/0
R2(config-if)#ip address 10.0.0.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay map ip 10.0.0.1 201 broadcast cisco

//Configure LMI type on an interface
R(config)#interface s0/0/0
R(config-uif)#frame-relay lmi-type [cisco|ansi|q933a]

//Troubleshoot commands
R#show frame-relay [lmi|map|route]
R#show ip interface s0/0/0
R#show interfaces s0/0/0

2. NBMA (Point-to-Point)

R1(config)#interface s0/0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shutdown
R1(config)#interface s0/0/0.1 point-to-point
R1(config-subif)#ip address 10.0.0.1 255.255.255.252
R1(config-subif)#frame-relay interface-dlci 102
R1(config-subif)#ip ospf network point-to-point     //only for ospf; rip and eigrp don’t require this

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s